$re = '/\A[\r\n]+|[\r\n]+$/m';
$str = '
z
h
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;