using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""".*?""(*SKIP)(?!)|(?<!\w)'.*?'(?!\w)(*SKIP)(?!)|[\w']+";
string input = @"This is some text, it isn't limited by single quotes in words like ""isn't"" for instance.
Text quoted in ""double quotes"" will not be counted.
Text quoted in 'single quotes' won't be either.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}