const regex = /".*?"(*SKIP)(?!)|(?<!\w)'.*?'(?!\w)(*SKIP)(?!)|[\w']+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('".*?"(*SKIP)(?!)|(?<!\\w)\'.*?\'(?!\\w)(*SKIP)(?!)|[\\w\']+', 'g')
const str = `This is some text, it isn't limited by single quotes in words like "isn't" for instance.
Text quoted in "double quotes" will not be counted.
Text quoted in 'single quotes' won't be either.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}