re = /".*?"(*SKIP)(?!)|(?<!\w)'.*?'(?!\w)(*SKIP)(?!)|[\w']+/
str = 'This is some text, it isn\'t limited by single quotes in words like "isn\'t" for instance.
Text quoted in "double quotes" will not be counted.
Text quoted in \'single quotes\' won\'t be either.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end