using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&\w{0,}?;";
string input = @"Os ser­viços do Pla­no 1 da Assis­tência";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}