package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`&\w{0,}?;`)
var str = `Os ser­viços do Pla­no 1 da Assis­tência`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}