using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=The|\s)(?:\s+?\w+)+|([\w\s-]*[^\d(HD, 1080p\)|\(HD, 720p\)|\(SD, 480p\)][^.flv|gif|mkv|mpeg|mpg|mov][^)(])+)";
string input = @"(HD, 1080p) (2005) Doing It Like A Cat.mpeg
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}