use strict;
my $str = '(HD, 1080p) (2005) Doing It Like A Cat.mpeg
';
my $regex = qr/((?<=The|\s)(?:\s+?\w+)+|([\w\s-]*[^\d(HD, 1080p\)|\(HD, 720p\)|\(SD, 480p\)][^.flv|gif|mkv|mpeg|mpg|mov][^)(])+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}