const regex = /((?<=The|\s)(?:\s+?\w+)+|([\w\s-]*[^\d(HD, 1080p\)|\(HD, 720p\)|\(SD, 480p\)][^.flv|gif|mkv|mpeg|mpg|mov][^)(])+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<=The|\\s)(?:\\s+?\\w+)+|([\\w\\s-]*[^\\d(HD, 1080p\\)|\\(HD, 720p\\)|\\(SD, 480p\\)][^.flv|gif|mkv|mpeg|mpg|mov][^)(])+)', '')
const str = `(HD, 1080p) (2005) Doing It Like A Cat.mpeg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}