# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{\{(?:(?!\}\}).)*?default=(.*?)\}\}/\1/gmi;t' <<< "It was a {{color, default=black}} and scary {{phase}}. As the {{animals, default=dogs}} {{make_sound, default=barked}} and the trees swayed {{setting, default=to the breeze}}, a {{size, default=}} {{monster, default=troll}} that emerged from the shadows."