const regex = /\{\{(?:(?!\}\}).)*?default=(.*?)\}\}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{(?:(?!\\}\\}).)*?default=(.*?)\\}\\}', 'gmi')
const str = `It was a {{color, default=black}} and scary {{phase}}. As the {{animals, default=dogs}} {{make_sound, default=barked}} and the trees swayed {{setting, default=to the breeze}}, a {{size, default=}} {{monster, default=troll}} that emerged from the shadows.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);