import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<capture_1>[\\w\\s\\-]+)\\((?P<capture_2>\\w)[\\s\\-]+(?P<capture_3>[\\S\\w]+)[\\s\\-]+(?P<capture_4>[\\s\\w]+)[\\s\\-]+\\[(?P<capture_5>[\\S\\w]+)[\\s\\-]+(?P<capture_6>[\\S\\w]+)[\\s\\-]+(?P<capture_7>[\\S\\w]+)\\]\\)";
final String string = "OLANZAPINE 10 MG - ORODISPERSIBLE TABLET (S - n/a - Drug withdrawn - [n/a - n/a - n/a])";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}