import re
regex = re.compile(r"^(?P<capture_1>[\w\s\-]+)\((?P<capture_2>\w)[\s\-]+(?P<capture_3>[\S\w]+)[\s\-]+(?P<capture_4>[\s\w]+)[\s\-]+\[(?P<capture_5>[\S\w]+)[\s\-]+(?P<capture_6>[\S\w]+)[\s\-]+(?P<capture_7>[\S\w]+)\]\)", flags=re.MULTILINE)
test_str = "OLANZAPINE 10 MG - ORODISPERSIBLE TABLET (S - n/a - Drug withdrawn - [n/a - n/a - n/a])"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")