re = /^(?P<capture_1>[\w\s\-]+)\((?P<capture_2>\w)[\s\-]+(?P<capture_3>[\S\w]+)[\s\-]+(?P<capture_4>[\s\w]+)[\s\-]+\[(?P<capture_5>[\S\w]+)[\s\-]+(?P<capture_6>[\S\w]+)[\s\-]+(?P<capture_7>[\S\w]+)\]\)/m
str = 'OLANZAPINE 10 MG - ORODISPERSIBLE TABLET (S - n/a - Drug withdrawn - [n/a - n/a - n/a])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end