using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#@]?\w+|\pP+|\S)";
string input = @"This is a common Tweet #format where @mentions and.errors!!!!like this:-)))))might #appear⤠â¤â¤#ThisIsAHashtag!?!";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}