re = /([#@]?\w+|\pP+|\S)/
str = 'This is a common Tweet #format where @mentions and.errors!!!!like this:-)))))might #appear⤠â¤â¤#ThisIsAHashtag!?!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end