using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^\)]*\]|\([^)]*\)";
string input = @"This is a test code [asdf -wer -a2 asdf] (ascd asdfas -were) test test test (testing test)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}