$re = '/\[[^\)]*\]|\([^)]*\)/';
$str = 'This is a test code [asdf -wer -a2 asdf] (ascd asdfas -were) test test test (testing test)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);