package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^\)]*\]|\([^)]*\)`)
var str = `This is a test code [asdf -wer -a2 asdf] (ascd asdfas -were) test test test (testing test)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}