using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=\s*(?:""[^""]*""|'[^']*'|\d+)(?:\s*,|\n))";
string substitution = @"#";
string input = @"""mahe,'ndra"", ""Gulla"" , 40 , 'te,st', 23
""mahe','ndra"", 'Gulla' , 40 , 'te,""st', 23
""mahe,n',,'dra"", 'Gulla' , 40 , ""te,st"", 23
'mahe"",""ndra', 'Gu""lla' , 40 , ""te,'st"", 23
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}