import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=\\s*(?:\"[^\"]*\"|'[^']*'|\\d+)(?:\\s*,|\\n))";
final String string = "\"mahe,'ndra\", \"Gulla\" , 40 , 'te,st', 23\n"
+ "\"mahe','ndra\", 'Gulla' , 40 , 'te,\"st', 23\n"
+ "\"mahe,n',,'dra\", 'Gulla' , 40 , \"te,st\", 23\n"
+ "'mahe\",\"ndra', 'Gu\"lla' , 40 , \"te,'st\", 23\n\n\n\n";
final String subst = "#";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}