$re = '/,(?=\s*(?:"[^"]*"|\'[^\']*\'|\d+)(?:\s*,|\n))/m';
$str = '"mahe,\'ndra", "Gulla" , 40 , \'te,st\', 23
"mahe\',\'ndra", \'Gulla\' , 40 , \'te,"st\', 23
"mahe,n\',,\'dra", \'Gulla\' , 40 , "te,st", 23
\'mahe","ndra\', \'Gu"lla\' , 40 , "te,\'st", 23
';
$subst = "#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;