package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[[:digit:]]{6}+[a-zA-Z]{1}`)
var str = `656765D`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}