$re = '/^[[:digit:]]{6}+[a-zA-Z]{1}/';
$str = '656765D';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);