const regex = /^[[:digit:]]{6}+[a-zA-Z]{1}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[[:digit:]]{6}+[a-zA-Z]{1}', '')
const str = `656765D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}