use strict;
my $str = 'A [[2008 Iwate-Miyagi Nairiku earthquake|6.9 magnitude earthquake]] in Iwate Prefecture, Japan, kills 12 and injures more than 400
[[December 1]] A triangular [[Conjunction (astronomy)|conjunction]] formed by a new Moon, Venus and Jupiter is a [[Conjunction (astronomy)#2008|prominent sight]] in the evening sky. [[December 2]]
';
my $regex = qr/\[{2}([^|]*?)(?:\|(.*?))?\]{2}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}