re = /\[{2}([^|]*?)(?:\|(.*?))?\]{2}/
str = 'A [[2008 Iwate-Miyagi Nairiku earthquake|6.9 magnitude earthquake]] in Iwate Prefecture, Japan, kills 12 and injures more than 400
[[December 1]] A triangular [[Conjunction (astronomy)|conjunction]] formed by a new Moon, Venus and Jupiter is a [[Conjunction (astronomy)#2008|prominent sight]] in the evening sky. [[December 2]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end