const regex = /(?<=add_image)_(?=\d+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=add_image)_(?=\\d+$)', 'gm')
const str = `add_image_1
add_image_1_2323
add_image_1_2323_09
add_image_134
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}