$re = '/(?<=add_image)_(?=\d+$)/m';
$str = 'add_image_1
add_image_1_2323
add_image_1_2323_09
add_image_134
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);