re = /(?<=add_image)_(?=\d+$)/m
str = 'add_image_1
add_image_1_2323
add_image_1_2323_09
add_image_134
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end