using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-+]?\d*\.?\d*)?([-+]\d*\.?\d*)[ijJ]";
string input = @"1+j unmatch
1+0j
-1+0j
1.1+0j
-1.1+0j
1.1+1j
1.1+1.1j
-1.1-1.1j
-1.1+1.1j
1.1-1.1j
-1.1j
5j unmatch
-5j
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}