re = /([-+]?\d*\.?\d*)?([-+]\d*\.?\d*)[ijJ]/
str = '1+j unmatch
1+0j
-1+0j
1.1+0j
-1.1+0j
1.1+1j
1.1+1.1j
-1.1-1.1j
-1.1+1.1j
1.1-1.1j
-1.1j
5j unmatch
-5j
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end