using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!Bean|Entity)([a-zA-Z]*)Manager\b";
string input = @"This works nice, but BeanManager and EntityManager are also included Manager AnyManager ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}