re = /\b(?!Bean|Entity)([a-zA-Z]*)Manager\b/
str = 'This works nice, but BeanManager and EntityManager are also included Manager AnyManager '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end