package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(?:\\.|[^"])*"|\S+`)
var str = `"search test" searchword2 -searchword3 "2\" by 4\""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}