$re = '/"(?:\\\\.|[^"])*"|\S+/';
$str = '"search test" searchword2 -searchword3 "2\\" by 4\\""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);