re = /"(?:\\.|[^"])*"|\S+/
str = '"search test" searchword2 -searchword3 "2\\" by 4\\""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end