package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[url=([^\]]+)\](.*?)\[\/url\]`)
var str = `world[url href=http://test.com]test[/url]hello
world[url=http://test.com]test[/url]hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}