re = /\[url=([^\]]+)\](.*?)\[\/url\]/i
str = 'world[url href=http://test.com]test[/url]hello
world[url=http://test.com]test[/url]hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end