$re = '/\[url=([^\]]+)\](.*?)\[\/url\]/i';
$str = 'world[url href=http://test.com]test[/url]hello
world[url=http://test.com]test[/url]hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);