#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)master(\D){0,30} informatique|master [2] (\D){0,3}informatique"
Local $sString = "Master Informatique" & @CRLF & _
"master en informatique" & @CRLF & _
"Master Spécialité informatique" & @CRLF & _
"master spécialisé en informatique" & @CRLF & _
"(master) spécialisée en informatique" & @CRLF & _
"master, en électronique ou en informatique" & @CRLF & _
"Master en Electronique ou Informatique" & @CRLF & _
"Master) avec une spécialisation en informatique" & @CRLF & _
"Master, MIAGE...), une expérience en informatique" & @CRLF & _
"Master en ingénierie - spécialité en Informatique" & @CRLF & _
"master, en électronique ou en informatique" & @CRLF & _
"master II en informatique" & @CRLF & _
"(Master II) en Informatique" & @CRLF & _
"master II, informatique" & @CRLF & _
"Master Data / Informatique " & @CRLF & _
"Master MIAGE ou Informatique" & @CRLF & _
"master 2 en informatique" & @CRLF & _
"Master 2 informatique" & @CRLF & _
"" & @CRLF & _
"Master), de préférence dans l’informatique" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Master RH, Informatique" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")