use strict;
my $str = 'Master Informatique
master en informatique
Master Spécialité informatique
master spécialisé en informatique
(master) spécialisée en informatique
master, en électronique ou en informatique
Master en Electronique ou Informatique
Master) avec une spécialisation en informatique
Master, MIAGE...), une expérience en informatique
Master en ingénierie - spécialité en Informatique
master, en électronique ou en informatique
master II en informatique
(Master II) en Informatique
master II, informatique
Master Data / Informatique
Master MIAGE ou Informatique
master 2 en informatique
Master 2 informatique
Master), de préférence dans l’informatique
Master RH, Informatique
';
my $regex = qr/master(\D){0,30} informatique|master [2] (\D){0,3}informatique/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}