// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)master(\D){0,30} informatique|master [2] (\D){0,3}informatique").unwrap();
let string = "Master Informatique
master en informatique
Master Spécialité informatique
master spécialisé en informatique
(master) spécialisée en informatique
master, en électronique ou en informatique
Master en Electronique ou Informatique
Master) avec une spécialisation en informatique
Master, MIAGE...), une expérience en informatique
Master en ingénierie - spécialité en Informatique
master, en électronique ou en informatique
master II en informatique
(Master II) en Informatique
master II, informatique
Master Data / Informatique
Master MIAGE ou Informatique
master 2 en informatique
Master 2 informatique
Master), de préférence dans l’informatique
Master RH, Informatique
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}