#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?'field'[a-z_]+)\s+(?'operator'eq|ne|gt|lt|ge|le)\s+(?'value'(?>'[\w\-:\s]+')|(?>[\w]+))(\s+(?'join'and|or))?)+"
Local $sString = "activity_id eq 9 and " & @CRLF & _
" status eq 'active asdf activity_id eq 9 and var gt 3' " & @CRLF & _
"status eq 'active' and activity_id eq 9 " & @CRLF & _
"activity_id eq 9 " & @CRLF & _
"status eq 'active' " & @CRLF & _
"status eq 'active asdf activity_id eq 9 and var gt 3' and activity_id eq 9" & @CRLF & _
"activity_id eq 9" & @CRLF & _
"status eq 'active' " & @CRLF & _
"status eq 'active" & @CRLF & _
" and done' " & @CRLF & _
"activity_id eq 9 and status eq 'active'" & @CRLF & _
"activity_id eq 9 or status eq 'active'" & @CRLF & _
"status eq 'active' " & @CRLF & _
"and activity_id eq 9" & @CRLF & _
"status eq 'active' or activity_id eq 9" & @CRLF & _
"status eq 'active and done' and activity_id eq 9" & @CRLF & _
"status eq 'active and done' or activity_id eq 9" & @CRLF & _
"activity_id eq 9 and start_date le '2021-03-20T00:00:00-00:00'" & @CRLF & _
"start_date le '2021-03-20T00:00:00-00:00'"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)