$re = '/((?\'field\'[a-z_]+)\s+(?\'operator\'eq|ne|gt|lt|ge|le)\s+(?\'value\'(?>\'[\w\-:\s]+\')|(?>[\w]+))(\s+(?\'join\'and|or))?)+/';
$str = 'activity_id eq 9 and
status eq \'active asdf activity_id eq 9 and var gt 3\'
status eq \'active\' and activity_id eq 9
activity_id eq 9
status eq \'active\'
status eq \'active asdf activity_id eq 9 and var gt 3\' and activity_id eq 9
activity_id eq 9
status eq \'active\'
status eq \'active
and done\'
activity_id eq 9 and status eq \'active\'
activity_id eq 9 or status eq \'active\'
status eq \'active\'
and activity_id eq 9
status eq \'active\' or activity_id eq 9
status eq \'active and done\' and activity_id eq 9
status eq \'active and done\' or activity_id eq 9
activity_id eq 9 and start_date le \'2021-03-20T00:00:00-00:00\'
start_date le \'2021-03-20T00:00:00-00:00\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;