import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?'field'[a-z_]+)\\s+(?'operator'eq|ne|gt|lt|ge|le)\\s+(?'value'(?>'[\\w\\-:\\s]+')|(?>[\\w]+))(\\s+(?'join'and|or))?)+";
final String string = "activity_id eq 9 and \n"
+ " status eq 'active asdf activity_id eq 9 and var gt 3' \n"
+ "status eq 'active' and activity_id eq 9 \n"
+ "activity_id eq 9 \n"
+ "status eq 'active' \n"
+ "status eq 'active asdf activity_id eq 9 and var gt 3' and activity_id eq 9\n"
+ "activity_id eq 9\n"
+ "status eq 'active' \n"
+ "status eq 'active\n"
+ " and done' \n"
+ "activity_id eq 9 and status eq 'active'\n"
+ "activity_id eq 9 or status eq 'active'\n"
+ "status eq 'active' \n"
+ "and activity_id eq 9\n"
+ "status eq 'active' or activity_id eq 9\n"
+ "status eq 'active and done' and activity_id eq 9\n"
+ "status eq 'active and done' or activity_id eq 9\n"
+ "activity_id eq 9 and start_date le '2021-03-20T00:00:00-00:00'\n"
+ "start_date le '2021-03-20T00:00:00-00:00'";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}