use strict;
my $str = 'exec]';
my $regex = qr/(?!<\[)\bexec(?!\])/p;
my $subst = 'EXECUTE';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";