$re = '/(?!<\[)\bexec(?!\])/';
$str = 'exec]';
$subst = "EXECUTE";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;