import Foundation
let pattern = #"(?!<\[)\bexec(?!\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"exec]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"EXECUTE"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)