use strict;
my $str = '/inga-rest/wallet/aaa
/inga-rest/wallet/MA503122/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA471075/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA471420/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/YYI9878/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA510926/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA299306/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA515464/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA473773/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA515578/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA215692/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA468301/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MV974901/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA486190/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA525372/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA470176/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA281510/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA464449/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA472241/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA482703/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA468533/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA459862/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA501495/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA162619/products?workflow=CERTIFIED_IDENTITY';
my $regex = qr//api/documentDownload/(.*)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}